CompoundStructureSampleHeight Property

The sample height is the presumed height of the wall to which the data in this CompoundStructure is applied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public double SampleHeight { get; set; }

Property Value

Double
The height of the wall used to define the vertically compound structure.
Exceptions
ExceptionCondition
ArgumentOutOfRangeException When setting this property: The value newSampleHeight is smaller than the value of MinimumSampleHeight.
InvalidOperationException This operation is valid only for vertically compound structures.
Remarks
This value has meaning only for vertically compound structures. In order to apply this CompoundStructure to a wall whose height differs from the sample height, the underlying grid will be rescaled.
See Also