PipeSettingsAddPipeSlope Method

Add a pipe slope value.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void AddPipeSlope(
	double slope
)

Parameters

slope  Double
The pipe slope value. Revit stores the slope value as a percentage (0-100).
Exceptions
ExceptionCondition
ArgumentOutOfRangeException The given value for slope must be between 0 and 100. Slope value is stored in percentage. e.g. 100 means 100%, and it is 45 degree.
InvalidOperationException Can not add a pipe slope value that was already added.
See Also