HermiteSplineCreate(IListXYZ, Boolean) Method

Creates a Hermite spline with default tangency at its endpoints.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static HermiteSpline Create(
	IList<XYZ> controlPoints,
	bool periodic
)

Parameters

controlPoints  IListXYZ
The control points of the Hermite spline.
periodic  Boolean
True if the Hermite spline is to be periodic, false otherwise.

Return Value

HermiteSpline
The new HermiteSpline object.
Exceptions
ExceptionCondition
ArgumentException The control points array is invalid, because it doesn't contain the minimum number of points (2).
ArgumentNullException A non-optional argument was NULL
ArgumentsInconsistentException Curve length is too small for Revit's tolerance (as identified by Application.ShortCurveTolerance).
InvalidOperationException Unable to construct valid HermiteSpline from given inputs.
Remarks
The tangents at the ends of the spline are computed from the control points.
See Also