BuiltInFailuresGridChainSketchFailures Class

Failures related to the GridChain sketch.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBBuiltInFailuresGridChainSketchFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class GridChainSketchFailures

The BuiltInFailuresGridChainSketchFailures type exposes the following members.

Properties
 NameDescription
Public propertyStatic memberClosedLoop GridChain sketch contains a closed loop.
Public propertyStatic memberInvalidSketch Sketch is invalid. Grid sketch must consist of a single open loop with no intersecting lines.
Public propertyStatic memberMoreThanOneLoop GridChain sketch contains more than one loop.
Public propertyStatic memberOverlappingLines GridChain sketch contains lines which overlap.
Top
See Also