RebarConstraintSetDistanceToTargetHostFace Method |
Sets the distance from the RebarConstrainedHandle to the target Host Element surface.
The RebarConstraintType of the RebarConstraint must be 'FixedDistanceToHostFace'.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetDistanceToTargetHostFace(
double offset
)
Public Sub SetDistanceToTargetHostFace (
offset As Double
)
public:
void SetDistanceToTargetHostFace(
double offset
)
member SetDistanceToTargetHostFace :
offset : float -> unit
Parameters
- offset Double
-
The distance is given as an offset value, the sign of which depends on Host Face direction.
ExceptionsException | Condition |
---|
ArgumentOutOfRangeException |
The given value for offset must be no more than 30000 feet in absolute value.
|
InvalidOperationException |
RebarConstraint is no longer valid.
-or-
The RebarConstraint is not of RebarConstraintType 'FixedDistanceToHostFace'.
|
See Also