IExtensionIsMiterLocked Property |
Retrieves or set the miter locked status at the end.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxbool this[
int index
] { get; set; }
Property IsMiterLocked (
index As Integer
) As Boolean
Get
Set
property bool IsMiterLocked[int index] {
bool get (int index);
void set (int index, bool value);
}
abstract IsMiterLocked : bool with get, set
Parameters
- index Int32
-
Property Value
Boolean
RemarksProperty index must be 0 or 1 to indicate two ends, otherwise exceptions will be thrown.
For beams, only if the beam is extended and is mitered with other beams at the end,
it can be locked. Otherwise, the setting is invalid
See Also