SubMenuItem Class

A class representing a menu flyout.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.UIMenuItem
    Autodesk.Revit.UISubMenuItem

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class SubMenuItem : MenuItem

The SubMenuItem type exposes the following members.

Constructors
 NameDescription
Public methodSubMenuItem Initialize the item data.
Top
Properties
 NameDescription
Top
Methods
 NameDescription
Top
Remarks

To add a child menu, create a new ContextMenu object and add MenuItem on it, pass the child ContextMenu object to SubMenuItem constructor and create SubMenuItem object, use AddItem() method to add the SubMenuItem object to parent ContextMenu.

See Also