SubMenuItem Class

A class representing a menu flyout.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.UIMenuItem
    Autodesk.Revit.UISubMenuItem

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class SubMenuItem : MenuItem

The SubMenuItem type exposes the following members.

Constructors
 NameDescription
Public methodSubMenuItem Initialize the item data.
Top
Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from MenuItem)
Top
Methods
 NameDescription
Public methodDispose
(Inherited from MenuItem)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks

To add a child menu, create a new ContextMenu object and add MenuItem on it, pass the child ContextMenu object to SubMenuItem constructor and create SubMenuItem object, use AddItem() method to add the SubMenuItem object to parent ContextMenu.

See Also