DirectShapeIsSupportedDocument Method |
Tests whether a DirectShape or a DirectShapeType may be created in this document.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsSupportedDocument(
Document document
)
Public Shared Function IsSupportedDocument (
document As Document
) As Boolean
public:
static bool IsSupportedDocument(
Document^ document
)
static member IsSupportedDocument :
document : Document -> bool
Parameters
- document Document
-
Document to be tested.
Return Value
Boolean
True if a DirectShape or a DirectShapeType object can be created in this document, false otherwise.
Exceptions
Remarks
Some types of Document, such as 2D families, can't support DirectShape functionality.
See Also