Retrieves or changes the visibility of the category in the active view.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool this[
View view
] { get; set; }
Public Property Visible (
view As View
) As Boolean
Get
Set
public:
property bool Visible[View^ view] {
bool get (View^ view);
void set (View^ view, bool value);
}
member Visible : bool with get, set
Parameters
- view View
-
Property Value
Boolean
RemarksThis affects only if the category is set visible or invisible individually. Other Revit mechanisms
may also affect the visibility of elements of this category, including:
- the category classes settings for
model categories, annotation categories, import categories or analytical model categories.
- view filters
Thus setting this value may not affect the actual visibility of elements of this category in the view.
See Also