ViewSystemsAnalysisReportCreate Method |
Creates a new view for the systems analysis report.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static ViewSystemsAnalysisReport Create(
Document document,
string viewName
)
Public Shared Function Create (
document As Document,
viewName As String
) As ViewSystemsAnalysisReport
public:
static ViewSystemsAnalysisReport^ Create(
Document^ document,
String^ viewName
)
static member Create :
document : Document *
viewName : string -> ViewSystemsAnalysisReport
Parameters
- document Document
-
The document where the view is to be created.
- viewName String
-
The name of the new report view.
Return Value
ViewSystemsAnalysisReport
The newly created view instance, or
if the operation fails.
ExceptionsException | Condition |
---|
ArgumentException |
viewName cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~".
-or-
viewName is an empty string.
|
ArgumentNullException |
A non-optional argument was null
|
InvalidOperationException |
The document is in failure mode: an operation has failed,
and Revit requires the user to either cancel the operation
or fix the problem (usually by deleting certain elements).
|
ModificationForbiddenException |
The document is in failure mode: an operation has failed,
and Revit requires the user to either cancel the operation
or fix the problem (usually by deleting certain elements).
-or-
The document is being loaded, or is in the midst of another
sensitive process.
|
ModificationOutsideTransactionException |
The document has no open transaction.
|
Remarks
A report instance is typically created to request a new systems analysis. The default values include the weather file "USA_CO_Denver.Intl.AP.725650_TMY3.epw" and
the workflow file "HVAC Systems Loads and Sizing.osw". Both are part of the Revit installation. The default output folder is the system TEMP folder.
See Also