The angle of the Connector.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic double Angle { get; set; }
Public Property Angle As Double
Get
Set
public:
property double Angle {
double get ();
void set (double value);
}
member Angle : float with get, set
Property Value
Double
Exceptions
RemarksAngle may be assigned for connectors of some family instances.
In order to set this property, it must be mapped to a writable instance parameter in the family definition.
For a connector obtained from a non-family instance (for example not a fitting, but instead a pipe, duct, or
cable tray), the value will always be zero. Non-zero angles are only valid for family instance fitting connectors.
See Also