CylindricalHelixCreate Method |
Create a cylindrical helix.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static CylindricalHelix Create(
XYZ basePoint,
double radius,
XYZ xVector,
XYZ zVector,
double pitch,
double startAngle,
double endAngle
)
Public Shared Function Create (
basePoint As XYZ,
radius As Double,
xVector As XYZ,
zVector As XYZ,
pitch As Double,
startAngle As Double,
endAngle As Double
) As CylindricalHelix
public:
static CylindricalHelix^ Create(
XYZ^ basePoint,
double radius,
XYZ^ xVector,
XYZ^ zVector,
double pitch,
double startAngle,
double endAngle
)
static member Create :
basePoint : XYZ *
radius : float *
xVector : XYZ *
zVector : XYZ *
pitch : float *
startAngle : float *
endAngle : float -> CylindricalHelix
Parameters
- basePoint XYZ
- Base point of the axis. It can be any point in 3d.
- radius Double
- Radius. It should be a positive number.
- xVector XYZ
- X vector. Should be Non-zero vector.
- zVector XYZ
- Z vector = axis direction. Should be non-zero and orthogonal to X Vector.
- pitch Double
- Pitch. It should be non-zero number, can be positive or negative.
Positive means right handed and negative means left handed.
- startAngle Double
- Start angle. It specifies the start point of the Helix.
- endAngle Double
- End angle. It specifies the end point of the Helix.
End angle should not be equal to start angle.
Return Value
CylindricalHelix
ExceptionsException | Condition |
---|
ArgumentException |
The radius is negative -or-
the pitch is zero -or-
the xVector or zVector is zero length -or-
zVector is not orthogonal to xVector -or-
endAngle is equal to startAngle.
|
See Also