LeaderAtachement Enumeration |
Supported types of vertical attachments of a leader to a text note.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum LeaderAtachement
Public Enumeration LeaderAtachement
public enum class LeaderAtachement
MembersMember name | Value | Description |
---|
TopLine | 0 |
Leaders are attached at the position of the top (first) line of the text box,
and, unless the text's border is visible, the leader's shoulder line extends
all the way to the text, minus the current value of text border offset.
|
Midpoint | 1 |
Leaders are aligned vertically with the midpoint of the text box and their shoulder line
always ends at the box' border regardless of whether the border is visible on not.
|
BottomLine | 2 |
Leaders are attached at the position of the bottom (last) line of the text box,
and, unless the text's border is visible, the leader's shoulder line extends
all the way to the text, minus the current value of text border offset.
|
See Also