FaceWallIsValidFaceReferenceForFaceWall Method |
Identifies if a reference may be used as the parent of a face wall.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsValidFaceReferenceForFaceWall(
Document document,
Reference faceReference
)
Public Shared Function IsValidFaceReferenceForFaceWall (
document As Document,
faceReference As Reference
) As Boolean
public:
static bool IsValidFaceReferenceForFaceWall(
Document^ document,
Reference^ faceReference
)
static member IsValidFaceReferenceForFaceWall :
document : Document *
faceReference : Reference -> bool
Parameters
- document Document
-
The document.
- faceReference Reference
-
The reference.
Return Value
Boolean
True if the reference is valid as a parent to a face wall, false otherwise.
Exceptions
Remarks
The reference must represent a face of a massing instance, and
must be planar, and its normal must not be vertical or horizontal.
See Also