ViewViewDirection Property |
The direction towards the viewer.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic XYZ ViewDirection { get; }
Public ReadOnly Property ViewDirection As XYZ
Get
public:
property XYZ^ ViewDirection {
XYZ^ get ();
}
member ViewDirection : XYZ with get
Property Value
XYZ
RemarksIn orthographic views, all objects are projected onto the screen along
this direction. In perspective views, the view target point is projected along
this direction, but other points are projected towards the eye along different
vectors.
See Also