BaseArrayLabel Property

The family parameter label of the BaseArray.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public FamilyParameter Label { get; set; }

Property Value

FamilyParameter
Exceptions
ExceptionCondition
ArgumentException Thrown when the family parameter's ParameterType is not ParameterType.Integer.
InvalidOperationException Thrown when trying to label the BaseArray out of family document.
Remarks
The label associates the number of members of the array with a family parameter. A BaseArray only can be labeled in a family document and only can be labeled to a integer FamilyParameter. To unbind the family parameter, set this property to .
See Also