StructuralSectionGeneralShape Enumeration

General shapes for structural sections.

Namespace: Autodesk.Revit.DB.Structure.StructuralSections
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public enum StructuralSectionGeneralShape
Members
Member nameValueDescription
NotDefined0 General shape is not defined.
GeneralI1 Defines parameters for Double T structural sections.
GeneralC2 Defines parameters for Channel Cold Formed structural sections.
GeneralU3 Defines parameters for Channel structural sections.
GeneralLA4 Defines parameters for Angle Cold Formed structural sections.
GeneralW5 Defines parameters for Angle structural sections.
GeneralT6 Defines parameters for Tees structural sections.
GeneralH7 Defines parameters for Rectangular Pipe structural sections.
GeneralS8 Defines parameters for Round Bar structural sections.
GeneralR9 Defines parameters for Pipe structural sections.
GeneralF10 Defines parameters for Flat Bar structural sections.
GeneralCEx11 Defines parameters for Channel With Fold Cold Formed structural sections.
GeneralLZ12 Defines parameters for Z Cold Formed structural sections.
See Also