ConnectorElementCreateCableTrayConnector(Document, Reference, Edge) Method |
Create a new cable tray ConnectorElement.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static ConnectorElement CreateCableTrayConnector(
Document document,
Reference planarFace,
Edge edge
)
Public Shared Function CreateCableTrayConnector (
document As Document,
planarFace As Reference,
edge As Edge
) As ConnectorElement
public:
static ConnectorElement^ CreateCableTrayConnector(
Document^ document,
Reference^ planarFace,
Edge^ edge
)
static member CreateCableTrayConnector :
document : Document *
planarFace : Reference *
edge : Edge -> ConnectorElement
Parameters
- document Document
-
The document to add the connector to.
- planarFace Reference
-
The planar face to place the connector on.
- edge Edge
-
One of the edges in the edge loop that defines the connector location on the planar face.
Return Value
ConnectorElement
The cable tray ConnectorElement.
Exceptions
Remarks
Regenerates the document.
See Also