SheetCollectionCreate(Document, String) Method |
Creates a new instance of sheet collection with a specified name and adds it to the document.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static SheetCollection Create(
Document document,
string name
)
Public Shared Function Create (
document As Document,
name As String
) As SheetCollection
public:
static SheetCollection^ Create(
Document^ document,
String^ name
)
static member Create :
document : Document *
name : string -> SheetCollection
Parameters
- document Document
-
The document where the sheet collection element will be created and added.
- name String
-
The name of new sheet collection.
Return Value
SheetCollection
The newly created sheet collection element.
ExceptionsException | Condition |
---|
ArgumentException |
name is an empty string or contains only whitespace.
-or-
name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~".
-or-
The given value for name is already in use as a sheet collection name.
|
ArgumentNullException |
A non-optional argument was null
|
InvalidOperationException |
The document is in failure mode: an operation has failed,
and Revit requires the user to either cancel the operation
or fix the problem (usually by deleting certain elements).
|
ModificationForbiddenException |
The document is in failure mode: an operation has failed,
and Revit requires the user to either cancel the operation
or fix the problem (usually by deleting certain elements).
-or-
The document is being loaded, or is in the midst of another
sensitive process.
|
ModificationOutsideTransactionException |
The document has no open transaction.
|
See Also