AnalyticalSurfaceBaseSetOuterContour Method |
Sets the Curve Loop that defines the geometry of the Analytical Surface element.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetOuterContour(
CurveLoop outerContour
)
Public Sub SetOuterContour (
outerContour As CurveLoop
)
public:
void SetOuterContour(
CurveLoop^ outerContour
)
member SetOuterContour :
outerContour : CurveLoop -> unit
Parameters
- outerContour CurveLoop
-
New Curve Loop for the Analytical Surface element.
Exceptions
Remarks
Curve Loop must be planar and not self-intersecting.
Example using (Transaction transaction = new Transaction(document, "Edit Analytical Panel outer contour"))
{
transaction.Start();
CurveLoop profileloop = new CurveLoop();
profileloop.Append(Line.CreateBound(
new XYZ(0, 0, 0), new XYZ(5, 0, 0)));
profileloop.Append(Line.CreateBound(
new XYZ(5, 0, 0), new XYZ(5, 5, 0)));
profileloop.Append(Line.CreateBound(
new XYZ(5, 5, 0), new XYZ(-2, 5, 0)));
profileloop.Append(Line.CreateBound(
new XYZ(-2, 5, 0), new XYZ(0, 0, 0)));
analyticalPanel.SetOuterContour(profileloop);
transaction.Commit();
}
}
Using transaction As Transaction = New Transaction(document, "Edit Analytical Panel outer contour")
transaction.Start()
Dim profileloop As CurveLoop = New CurveLoop()
profileloop.Append(Line.CreateBound(New XYZ(0, 0, 0), New XYZ(5, 0, 0)))
profileloop.Append(Line.CreateBound(New XYZ(5, 0, 0), New XYZ(5, 5, 0)))
profileloop.Append(Line.CreateBound(New XYZ(5, 5, 0), New XYZ(-2, 5, 0)))
profileloop.Append(Line.CreateBound(New XYZ(-2, 5, 0), New XYZ(0, 0, 0)))
analyticalPanel.SetOuterContour(profileloop)
transaction.Commit()
End Using
End If
No code example is currently available or this language may not be supported.
No code example is currently available or this language may not be supported.
Using transaction As Transaction = New Transaction(document, "Edit Analytical Panel outer contour")
transaction.Start()
Dim profileloop As CurveLoop = New CurveLoop()
profileloop.Append(Line.CreateBound(New XYZ(0, 0, 0), New XYZ(5, 0, 0)))
profileloop.Append(Line.CreateBound(New XYZ(5, 0, 0), New XYZ(5, 5, 0)))
profileloop.Append(Line.CreateBound(New XYZ(5, 5, 0), New XYZ(-2, 5, 0)))
profileloop.Append(Line.CreateBound(New XYZ(-2, 5, 0), New XYZ(0, 0, 0)))
analyticalPanel.SetOuterContour(profileloop)
transaction.Commit()
End Using
End If
See Also