RebarContainerItemSetLayoutAsMinimumClearSpacing Method |
Sets the Layout Rule property of rebar set to MinimumClearSpacing
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetLayoutAsMinimumClearSpacing(
double spacing,
double arrayLength,
bool barsOnNormalSide,
bool includeFirstBar,
bool includeLastBar
)
Public Sub SetLayoutAsMinimumClearSpacing (
spacing As Double,
arrayLength As Double,
barsOnNormalSide As Boolean,
includeFirstBar As Boolean,
includeLastBar As Boolean
)
public:
void SetLayoutAsMinimumClearSpacing(
double spacing,
double arrayLength,
bool barsOnNormalSide,
bool includeFirstBar,
bool includeLastBar
)
member SetLayoutAsMinimumClearSpacing :
spacing : float *
arrayLength : float *
barsOnNormalSide : bool *
includeFirstBar : bool *
includeLastBar : bool -> unit
Parameters
- spacing Double
-
The maximum spacing between rebar in rebar set
- arrayLength Double
-
The distribution length of rebar set
- barsOnNormalSide Boolean
-
Identifies if the bars of the rebar set are on the same side of the rebar plane indicated by the normal
- includeFirstBar Boolean
-
Identifies if the first bar in rebar set is shown
- includeLastBar Boolean
-
Identifies if the last bar in rebar set is shown
Exceptions
Remarks
When changing the layout rule to MinimumClearSpacing, you must also simultaneously set Spacing,
SetLength, BarsOnNormalSide, IncludeFirstBar, and IncludeLastBar properties.
See Also