CompoundStructureIsVerticallyHomogeneous Method |
Indicates whether this CompoundStructure represents a single set of parallel layers.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsVerticallyHomogeneous()
Public Function IsVerticallyHomogeneous As Boolean
public:
bool IsVerticallyHomogeneous()
member IsVerticallyHomogeneous : unit -> bool
Return Value
Boolean
True if this CompoundStructure represents a series of parallel layers that stretch from bottom to top, false otherwise.
Remarks
Differs from IsVerticallyCompound as a vertically compound structure might happen not to have
any horizontal breaks. For that situation, both IsVerticallyCompound and this method will return true.
See Also