DocumentExport(String, String, IFCExportOptions) Method |
Exports the document to the Industry Standard Classes (IFC) format.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool Export(
string folder,
string name,
IFCExportOptions options
)
Public Function Export (
folder As String,
name As String,
options As IFCExportOptions
) As Boolean
public:
bool Export(
String^ folder,
String^ name,
IFCExportOptions^ options
)
member Export :
folder : string *
name : string *
options : IFCExportOptions -> bool
Parameters
- folder String
-
Output folder into which the file will be exported. The folder must exist.
- name String
-
Either the name of a single file or a prefix for a set of files.
If empty, automatic naming will be used.
- options IFCExportOptions
-
Various options applicable to the IFC format.
If , all options will be set to their respective default values.
Return Value
Boolean
True if successful, otherwise False.
Exceptions
Remarks
Exporting to IFC requires that document is modifiable, therefore there must be a transaction already open when this method is called.
This method may not be invoked during dynamic update, for the internal routine might need to modify the existing transaction.
See Also