DocumentGetRoomAtPoint(XYZ, Phase) Method

Gets a room containing the point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Room GetRoomAtPoint(
	XYZ point,
	Phase phase
)

Parameters

point  XYZ
Point to be checked.
phase  Phase
Phase in which the room exists.

Return Value

Room
The room containing the point.
Exceptions
ExceptionCondition
ArgumentNullException Thrown when the point is .
ArgumentException Thrown when the coordinates of the point are not number or are Double::MaxValue or Double::MinValue.
Remarks
If phase is , it will get the room of the last phase.The first one found will be returned. If there is no room containing the point, it returns .
See Also