DuctFittingAndAccessoryData Class

The input data used by external servers for calculation of the duct fitting and duct accessory coefficient.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.MechanicalDuctFittingAndAccessoryData

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DuctFittingAndAccessoryData : IDisposable

The DuctFittingAndAccessoryData type exposes the following members.

Properties
 NameDescription
Public propertyAirViscosity The kinematic viscosity of air for the duct fitting or duct accessory, Units: (ft^2/s).
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyOrigin The origin position of the duct fitting or duct accessory.
Public propertyPartType The part type of the duct fitting or duct accessory.
Public propertyServerGUID The GUID of the duct fitting or duct accessory.
Public propertySystemClassification The system classification of the duct fitting or duct accessory.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the DuctFittingAndAccessoryData
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetAllConnectorData Gets the connector data of the pipe fitting or pipe accessory.
Public methodGetEntity Returns an Entity of the Schema of the serverGUID. or an invalid entity otherwise.
Public methodGetFamilyInstanceId Gets the Id of the fiting or accessory instance
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
A FamilyInstance is the input data for the calculation,
See Also