FloorGetVerticalProjectionPoint Method |
Return a surface point on either the top or bottom face of a floor slab corresponding to the vertical projection
of an arbitrary point in project space.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic XYZ GetVerticalProjectionPoint(
XYZ modelLocation,
FloorFace floorFace
)
Public Function GetVerticalProjectionPoint (
modelLocation As XYZ,
floorFace As FloorFace
) As XYZ
public:
XYZ^ GetVerticalProjectionPoint(
XYZ^ modelLocation,
FloorFace floorFace
)
member GetVerticalProjectionPoint :
modelLocation : XYZ *
floorFace : FloorFace -> XYZ
Parameters
- modelLocation XYZ
- A point in project coordinates that will be projected to the slab top or bottom face.
- floorFace FloorFace
- A flag determining whether the top or bottom face of the floor should be used.
Return Value
XYZ Slab surface point for the vertically projected model point.
Remarks If the floor is shape edited, the surface location must be within the boundaries of a face on the slab.
Otherwise the method will return .
See Also