TransformCreateReflection Method |
Creates a transform that represents a reflection across the given plane.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static Transform CreateReflection(
Plane plane
)
Public Shared Function CreateReflection (
plane As Plane
) As Transform
public:
static Transform^ CreateReflection(
Plane^ plane
)
static member CreateReflection :
plane : Plane -> Transform
Parameters
- plane Plane
-
The plane.
Return Value
Transform
The new transform.
Exceptions
Exampleprivate Transform Reflect(ReferencePlane refPlane)
{
Transform mirTrans = Transform.CreateReflection(refPlane.GetPlane());
return mirTrans;
}
Private Function Reflect(refPlane As ReferencePlane) As Transform
Dim mirTrans As Transform = Transform.CreateReflection(refPlane.GetPlane())
Return mirTrans
End Function
No code example is currently available or this language may not be supported.
No code example is currently available or this language may not be supported.
See Also