DirectShapeReferenceOptionsIsValidExternalGeometryId Method |
Validates that the input ExternalGeometryId can be assigned to a direct shape reference.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsValidExternalGeometryId(
ExternalGeometryId externalId
)
Public Shared Function IsValidExternalGeometryId (
externalId As ExternalGeometryId
) As Boolean
public:
static bool IsValidExternalGeometryId(
ExternalGeometryId^ externalId
)
static member IsValidExternalGeometryId :
externalId : ExternalGeometryId -> bool
Parameters
- externalId ExternalGeometryId
-
The ExternalGeometryId to assign to the reference.
Return Value
Boolean
True if the provided ExternalGeometryId is valid, false otherwise.
Exceptions
See Also