ViewScheduleGetSegmentHeight Method |
Gets the segment height.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic double GetSegmentHeight(
int segmentIndex
)
Public Function GetSegmentHeight (
segmentIndex As Integer
) As Double
public:
double GetSegmentHeight(
int segmentIndex
)
member GetSegmentHeight :
segmentIndex : int -> float
Parameters
- segmentIndex Int32
-
Zero-based index of the segment.
Return Value
Double
The segment height value.
ExceptionsException | Condition |
---|
ArgumentException |
The segment index should start from 0 and be less than the total segment count.
|
Remarks
The height is Revit's internal units value of schedule header and segment body.
The real height of segment on sheet may be less than the segment height get here.
It is the border height of segment instance on sheet.
The last segment height get here is the max value of double as the last segment height is not set
to a fix value. It will be determined by whole schedule height and other segments' heights. And the border for it is max value of double.
See Also