DocumentImport(String, GBXMLImportOptions) Method

Imports a Green-Building XML file into the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool Import(
	string file,
	GBXMLImportOptions options
)

Parameters

file  String
Full path of the file to import. File must exist.
options  GBXMLImportOptions
Various options applicable to GBXml import. If , all options will be set to their respective default values.

Return Value

Boolean
True if successful, otherwise False.
Exceptions
ExceptionCondition
ArgumentNullExceptionThrown when file argument is or empty.
FileNotFoundExceptionThrown when the file specified does not exist.
ArgumentExceptionThrown when no file is specified or if the file is not a valid gbXML file or does not contain any result elements.
Remarks
This method is available only in MEP. Though the 'options' argument is not currently used, an object still must be provided (may be ). The method will return False if not succeed. e.g when the input xml file does not contain any result elements.
See Also