ElementMulticlassFilter(IListType, Boolean) Constructor |
Constructs a new instance of a filter to find elements whose Element subclasses matches any of a given set of input classes, with an option to instead match
elements whose Element subclass does not match the list of input classes.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementMulticlassFilter(
IList<Type> typeList,
bool inverted
)
Public Sub New (
typeList As IList(Of Type),
inverted As Boolean
)
public:
ElementMulticlassFilter(
IList<Type^>^ typeList,
bool inverted
)
new :
typeList : IList<Type> *
inverted : bool -> ElementMulticlassFilter
Parameters
- typeList IListType
-
The list of Element subclass types to match.
- inverted Boolean
-
True if the filter should match all elements which are not of the given Element subclass.
ExceptionsException | Condition |
---|
ArgumentException |
One or more input types are not valid subclasses of Element for this filter.
-or-
One or more of the types do not exist in Revit's native object model.
|
ArgumentNullException |
A non-optional argument was null
|
See Also