ConnectorElementCreateConduitConnector(Document, Reference) Method

Create a new conduit ConnectorElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ConnectorElement CreateConduitConnector(
	Document document,
	Reference planarFace
)

Parameters

document  Document
The document to add the connector to.
planarFace  Reference
The planar face to place the connector on.

Return Value

ConnectorElement
The conduit ConnectorElement.
Exceptions
ExceptionCondition
ArgumentException The reference is not a planar face. -or- document is not a family document.
ArgumentNullException A non-optional argument was null
InvalidOperationException Connector creation is not allowed in this family.
Remarks
Regenerates the document.
See Also