AnalyticalMemberSetReleaseConditions Method

Sets Release Conditions to Analytical Member.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetReleaseConditions(
	ReleaseConditions releaseConditions
)

Parameters

releaseConditions  ReleaseConditions
End to which release conditions will be added is defined by setting [!:Autodesk::Revit::DB::Structure::ReleaseConditions::Position] property in provided release conditions object.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
Remarks
If element already have release conditions defined for that end, newly provided values replace current one. The ReleaseType will be set to UserDefined.
See Also