PointCloudInstanceSetSelectionFilter Method |
Sets active selection filter by cloning of the one passed to it.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetSelectionFilter(
PointCloudFilter pFilter
)
Public Sub SetSelectionFilter (
pFilter As PointCloudFilter
)
public:
void SetSelectionFilter(
PointCloudFilter^ pFilter
)
member SetSelectionFilter :
pFilter : PointCloudFilter -> unit
Parameters
- pFilter PointCloudFilter
-
The filter object to be made active. If is supplied, the
active filter is removed.
Remarks
The filter is provided in the coordinates of the Revit model. If the point cloud is
altered (e.g. by moving, rotating, scaling or other modifications) the point cloud
filter is not modified and the set of highlighted or isolated points will change.
The selection filter is not preserved when the Revit document is saved.
See Also