An enumerated type listing possible target units for CAD Import.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
SyntaxPublic Enumeration ImportUnit
public enum class ImportUnit
MembersMember name | Value | Description |
---|
Default | 0 |
Unit (if available) from the document that is getting imported.
|
Foot | 1 |
Feet and Inches in fractional notation.
|
Inch | 2 |
Inches in fractional notation.
|
Meter | 3 |
Meters as decimal values.
|
Decimeter | 4 |
Decimeters as decimal values.
|
Centimeter | 5 |
Centimeters as decimal values.
|
Millimeter | 6 |
Millimeters as decimal values.
|
Custom | 7 |
Custom values as decimal values
|
USSurveyFoot | 8 |
US survey feet as decimal values
|
See Also