EdgeIsFlippedOnFace(Int32) Method |
Determines if this edge's topological direction on the Face is opposite to its parametric direction.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsFlippedOnFace(
int index
)
Public Function IsFlippedOnFace (
index As Integer
) As Boolean
public:
bool IsFlippedOnFace(
int index
)
member IsFlippedOnFace :
index : int -> bool
Parameters
- index Int32
- The index of the face (0 or 1).
Return Value
Booleantrue if this edge's topological direction on the Face is opposite to its parametric direction, false if the topological direction agrees with the parametric direction.
Exceptions
RemarksOuter edge loops on a Face are oriented counter-clockwise with respect to the Face's orientation,
and inner loops are oriented clockwise. The topological direction of an edge on a face means the direction
in which the edge's loop is being traversed.
See Also