ViewSetBackground Method

Sets the background for the view. Background can only be set for 3d views and for Sections/Elevations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetBackground(
	ViewDisplayBackground background
)

Parameters

background  ViewDisplayBackground
Background to set. See 'ViewDisplayBackground' class and its 'create' methods.
Exceptions
ExceptionCondition
ArgumentException The background object is invalid, or view has 'Rendering' style.
ArgumentNullException A non-optional argument was null
InvalidOperationException This view does not contain display-related properties.
See Also