FilteredElementCollectorWhereElementIsElementType Method

Applies an ElementIsElementTypeFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public FilteredElementCollector WhereElementIsElementType()

Return Value

FilteredElementCollector
A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.
Remarks
Only elements that are ElementTypes will pass the collector. If you have an active iterator to this collector it will be stopped by this call.
See Also