ElementMulticategoryFilter(ICollectionBuiltInCategory, Boolean) Constructor |
Constructs a new instance of a filter to match elements by built-in category, with the option to match all elements which are not of the given category.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementMulticategoryFilter(
ICollection<BuiltInCategory> categories,
bool inverted
)
Public Sub New (
categories As ICollection(Of BuiltInCategory),
inverted As Boolean
)
public:
ElementMulticategoryFilter(
ICollection<BuiltInCategory>^ categories,
bool inverted
)
new :
categories : ICollection<BuiltInCategory> *
inverted : bool -> ElementMulticategoryFilter
Parameters
- categories ICollectionBuiltInCategory
-
The built-in categories to match.
- inverted Boolean
-
True if the filter should match all elements which are not of the given built-in categories.
See Also