RebarShapeVertexTurn Property |
The sense of the turn. The Turn property must be set to Left or Right on each internal vertex
before the RebarShapeDefinitionBySegments is used.
Default is permissible for the first and last vertex, since they do not correspond to bends.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic RebarShapeVertexTurn Turn { get; set; }
Public Property Turn As RebarShapeVertexTurn
Get
Set
public:
property RebarShapeVertexTurn Turn {
RebarShapeVertexTurn get ();
void set (RebarShapeVertexTurn value);
}
member Turn : RebarShapeVertexTurn with get, set
Property Value
RebarShapeVertexTurn
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: turn must be Left or Right.
|
ArgumentOutOfRangeException |
When setting this property: A value passed for an enumeration argument is not a member of that enumeration
|
See Also