TransformScale Property

The real number that represents the scale of the transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public double Scale { get; }

Property Value

Double
Exceptions
ExceptionCondition
InvalidOperationException Thrown when this transformation is not conformal and the scale is undefined.
Remarks
When the transformation is conformal and can be decomposed as the product of a rigid-body motion, uniform scale and reflection, this property returns the scale value of the uniform scale transformation.
See Also