RebarConstraintGetDistanceToTargetRebar Method |
Gets the distance from the RebarConstrainedHandle to the target Rebar handle surface.
The RebarConstraintType of the RebarConstraint must be 'ToOtherRebar'.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic double GetDistanceToTargetRebar()
Public Function GetDistanceToTargetRebar As Double
public:
double GetDistanceToTargetRebar()
member GetDistanceToTargetRebar : unit -> float
Return Value
Double
Returns the distance from the RebarConstrainedHandle to the target Rebar handle surface.
ExceptionsException | Condition |
---|
InvalidOperationException |
RebarConstraint is no longer valid.
-or-
The RebarConstraint is not of RebarConstraintType 'ToOtherRebar'.
-or-
The RebarTargetConstraintType is 'HookBend' or 'BarBend'.
|
Remarks
Throws exception if the constraint is not to other rebar or if the target constraint is to bar bend or hook bend.
See Also