CompoundStructureGetExtendableRegionIds Method |
Gets the extendable region ids for the compound structure.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<int> GetExtendableRegionIds(
bool top
)
Public Function GetExtendableRegionIds (
top As Boolean
) As IList(Of Integer)
public:
IList<int>^ GetExtendableRegionIds(
bool top
)
member GetExtendableRegionIds :
top : bool -> IList<int>
Parameters
- top Boolean
-
If true, retrieve ids of regions which are extendable at the top, otherwise
retrieve the ids of regions which are extendable at the bottom.
Return Value
IListInt32
An array of region ids which are marked extendable.
Exceptions
Remarks
Regions along the top or bottom of the wall may be set to be extendable.
See Also