RebarShapeParametersIsValidExternalDefinition Method

Checks that an ExternalDefinition (shared parameter) may be used as a Rebar Shape parameter.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool IsValidExternalDefinition(
	ExternalDefinition param
)

Parameters

param  ExternalDefinition
Definition of a shared parameter.

Return Value

Boolean
True if the definition is of type Length, false otherwise.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was
Remarks
A Rebar Shape parameter must be an ExternalDefinition with a ParameterType of Length.
See Also