BoundaryConditionsGetDegreesOfFreedomCoordinateSystem Method |
Gets the origin and rotation of coordinate system that is used by translation and rotation parameters, like X Translation or Z Rotation.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Transform GetDegreesOfFreedomCoordinateSystem()
Public Function GetDegreesOfFreedomCoordinateSystem As Transform
public:
Transform^ GetDegreesOfFreedomCoordinateSystem()
member GetDegreesOfFreedomCoordinateSystem : unit -> Transform
Return Value
Transform
The coordinate system. Origin contains the position of the start of the boundary conditions. BasisX, BasisY and BasisZ contain the directions of the axes in the global coordinate system.
See Also