EnergyAnalysisDetailModelOptionsEnergyModelType Property

It indicates whether the energy model is based on rooms/spaces or building elements.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public EnergyModelType EnergyModelType { get; set; }

Property Value

EnergyModelType
Exceptions
ExceptionCondition
ArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks
The default value is EnergyModelType::SpatialElement.
See Also