IFCExportOptionsAddOption Method |
Adds a new named option to the options structure.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void AddOption(
string name,
string value
)
Public Sub AddOption (
name As String,
value As String
)
public:
void AddOption(
String^ name,
String^ value
)
member AddOption :
name : string *
value : string -> unit
Parameters
- name String
-
The option name.
- value String
-
The option value.
Exceptions
Remarks
Named options can be used to set options not accessible through the standard IFC export user interface.
It is up to the implementation of the IExporterIFC interface to customize export behavior based on these options.
See Also