IPerformanceAdviserRuleGetElementFilter Method |
Retrieves a filter to restrict elements to be checked.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
SyntaxElementFilter GetElementFilter(
Document document
)
Function GetElementFilter (
document As Document
) As ElementFilter
ElementFilter^ GetElementFilter(
Document^ document
)
abstract GetElementFilter :
document : Document -> ElementFilter
Parameters
- document Document
-
Document for which performance problems are being checked.
Return Value
ElementFilter
The filter to restrict elements to be checked.
Remarks
If the rule needs to be executed on individual elements,
it should return a filter that defines what elements the rule should apply to.
Otherwise, nothing (i.e. null) should be returned.
If filter is returned, it should stay valid till the end of the check.
See Also