MechanicalEquipmentSetTypeCreate Method

Creates a new type of a mechanical equipment set and adds it to the document.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static MechanicalEquipmentSetType Create(
	Document document,
	string name
)

Parameters

document  Document
The document where the new type is created.
name  String
The name of new type.

Return Value

MechanicalEquipmentSetType
The newly created mechanical equipment set type.
Exceptions
ExceptionCondition
ArgumentException name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- name is an empty string. -or- The given name is not unique
ArgumentNullException A non-optional argument was null
InvalidOperationException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
ModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException The document has no open transaction.
See Also