GeometryInstanceSymbolGeometry Property |
The geometric representation of the symbol which generates this instance.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic GeometryElement SymbolGeometry { get; }
Public ReadOnly Property SymbolGeometry As GeometryElement
Get
public:
property GeometryElement^ SymbolGeometry {
GeometryElement^ get ();
}
member SymbolGeometry : GeometryElement with get
Property Value
GeometryElement
RemarksThe geometry will be in the local coordinate space of the symbol.
The context of this instance object (such as effective material) will be applied to the symbol.
Note that retrieving the value of this property involves extensive parsing or Revit's data
structures, so try to minimize calls if performance is critical.
Geometry will be parsed with the same options as those used when this object was retrieved.
The value of this property and the results of the method GetSymbolGeometry(void) are identical.
See Also